Pull request ElementsProject/lightning#6490

Fix: Remove Sync requirements on Futures returned in the Rust plugin library.

Range Diff Matrix